wordpressで画像編集ができない!! 

症状

wordpressでアップロードした画像メディアのサイズを変更しようとしたらエラーが起きた。

pictureobj

“ご利用中のホスティング環境は画像の回転機能に対応していません。”
他のサイトではfunction.phpに空白行があるのが原因だとか紹介されていたが自分の場合は違った。

原因

原因は画像処理に必要なライブラリである”gd”がインストールされていなかったからだった。

解決方法

サーバーはUbuntu Serverを利用している。

サーバーにログインしたら必要なパッケージをインストールすればよい。

$sudo apt-get install php5-gd

centosサーバーでは次のコマンドでインストールする。

$yum install gd
$yum install php-gd